Announcement Announcement Module
Collapse
No announcement yet.
CGMiner Status Running (Connect to CGMiner API failed) v0.97 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • CGMiner Status Running (Connect to CGMiner API failed) v0.97

    I've enabled all params
    CGMiner API Enabled

    CGMiner Remote Management Enabled

    and restarted

    but v0.97 says
    Mining Status

    CGMiner Status Running (Connect to CGMiner API failed)
    Last Checked
    Avg. Hash Rate
    WU
    Difficulty Accepted
    HW Status


    No data shown ?

  • #2
    I have the same issue, any suggestions?


    Comment


    • #3
      Does Pool reports any hashing speed? IE - if its only a problem of showing stats on KNCminer admin panel or miner dont mine at all. You can check through SSH - connect to Your miner IP with SSH and check if its running by issueing 'screen -r' command in terminal window. You should see CGminer details

      Comment


      • #4
        After 97 update and connection failure CGMiner shows config file error (seen in KNCMiner admin panel in Mining area). Manual configuration screen pops up and manual config is required. During this time temp has dropped significantly - and previous GH rate has dropped to low MH hashing rate per putty screen. Anyone know how to manually configure CGMiner miner settings?
        Last edited by ChillyBilly; 26th October 2013, 11:45 AM.

        Comment


        • #5
          * Running (Connect to CGMiner API failed)

          I've got this error too but with .98 installed. Slush pool says I'm hashing over 100g on my Mercury, but I'm not sure how to fix this error so that it shows some stats.

          Comment


          • #6
            Same problem here with my Saturn.. This happened suddenly after 1 week of running stable the v0.99 firmware. Anyone?

            Comment


            • #7
              Same problem here with my Saturn.. This happened suddenly after 1 week of running stable the v0.99 firmware. Anyone?

              Comment


              • #8
                Do a hard reset and see if that helps. press the button 5 times, and wait 5 seconds and 5 more times. If not download the latest version of CGminer. It contains instructions on basic configuration settings for CGminer, so it should be simple to do. For the KNC miner, it's very simple as follows. Just put in your pool info in it.

                {
                "pools": [
                {
                "url": "YOUR_POOL_URL",
                "user": "WORKER_NAME",
                "pass": "WORKER_PASSWORD"
                }
                ],
                "api-listen": true,
                "api-network": true,
                "api-allow": "W:0/0"
                }

                Comment


                • AvenG
                  AvenG commented
                  Editing a comment
                  Thanks for your reply, unfortunately the hard reset didn't work.. I also tried few more things and everything went worst.. now the CGMiner Status: Halted (Check Miner Settings). I realized that the "API Enable" feature disappeared from the screen !

                  BTW, I don't understand how to download and edit the CGminer that you mention. Could you elaborate it ?

              • #9
                I'm having this issue right now. It eventually came back online however I tried to change pool settings again and restart cgminer but it's giving me the same Halted error.

                Comment


                • jmevz
                  jmevz commented
                  Editing a comment
                  Found the error to be incorrect worker details in the mining fields. All good now!

              • #10
                Hi, I am having the same issue with my October box but not the November batch. Checked pool urls and worker. Why does it work on one and not the other? Have anyone solved this issue? thanks

                Comment

                Working...
                X